Back to overview
Degraded
SuperPay 1-Day Payment Delays Impacting Some Users
Mar 20 at 09:00am CDT
Affected services
SuperPay
Resolved
Mar 20 at 10:00am CDT
We want to assure you that our team is actively working on a solution that will be implemented by Monday, March 24th.
Affected services
SuperPay
Created
Mar 20 at 09:00am CDT
We are aware that there is an issue causing some carriers to experience a 1-day delay in payments.
Affected services
SuperPay