Back to overview
Degraded
Carrier TMS performance degradation
Apr 29, 2026 at 1:43pm UTC
Affected services
Carrier TMS
Carrier TMS API
Resolved
Apr 29, 2026 at 2:42pm UTC
This issue have been resolved. Our team is working on pushing more improvements.
Affected services
Created
Apr 29, 2026 at 1:43pm UTC
Carrier TMS and Carrier API is experiencing performance degradation due to database infrastructure issues. Our Engineering team is working on resolution.
Affected services